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General
Why should I use MediaPortal?
Review the MediaPortal Features to see why you should use MediaPortal over other media center software. See what some of MediaPortal's users have
to say about "Why everything else is just a Media Center".

Does MediaPortal run on Linux?
MediaPortal has been designed for Windows and will not run on Linux. Myth TV is a similar project designed specifically for Linux.

Does MediaPortal run on Windows MCE2005?
Yes, it does - out of the box. As Windows MCE is basically XP, all XP requirements also apply for MCE. See our Requirements page - especially the
required updates tab for XP / MCE2005. The MCE services are stopped by MediaPortal as well automatically.

Does MediaPortal run on Windows Vista (Service Pack 1)?
Yes, it does provided User Account Control is turned off in the Windows Control Panel (click on User Accounts).

Does MediaPortal run on Windows 7
Yes, since version 1.1 Windows 7 is officially supported by MediaPortal.

Does MediaPortal run on Windows 2000, Windows XP (Pre Service Pack 2)32 bit version or
Windows XP 64 bit Version?
MediaPortal will NOT install on Windows 2000, Windows XP 32 bit version (pre Service Pack 2) or Windows XP 64 bit version. See: Requirements

Does MediaPortal run on Windows Vista (pre Service Pack 1) , Windows Server 2003 ,
Windows Server 2008 or Windows XP/Vista with Beta Service Pack versions?
These versions of windows are not officially supported by the MediaPortal Team. Windows 2000 and the server versions of Windows lack the Stream
Buffer Engine (SBE) by Microsoft which MediaPortal relies on for watching TV. See: Requirements

I am using a stripped down or streamlined version of XP. Why does MediaPortal run so badly on
it?
Stripped down Windows versions mostly lack of some basic services and settings MediaPortal uses. We cannot supply a list of services that have to be
installed, as some plugins need services that others don't. In general we recommend not to used a stripped version of Windows. You might experience
some very weird things and unexpected crashes with it. The same applies if you disable some Windows services by hand. You cannot predict what plugin
component is going to need what service.

MediaPortal Freezes/Locks Up within seconds of the GUI showing on Windows XP ONLY.
A current problem with 690G chipset / x1250 GPU has the inability to perform a certain standard .NET 2 function called reflections ("FLIPX" or "FLIPY").
MediaPortal uses this standard function frequently throughout its skins. The desktop appears to freeze or lockup but navigation through the GUI still
occurs, only noticeable through sounds events. Changing between full screen or windowed mode (by pressing ALT + ENTER) will refresh the GUI to the
navigation key strokes pressed after the freeze/lockup but will freeze/lockup again within seconds.. NOTE:- This only occurs on operating systems with
Windows XP (all Service Packs). To resolve this issue, drivers of Catalyst Control Center (CCC) 7.2 or lower must be used. Alternatively, if the later drivers
are used/required, modified skin files can be used which do not use this standard .NET 2 feature and will eliminate the freeze/lockup issue. These can be
found in the following forum thread, https://forum.team-mediaportal.com/ge...roblems-29894/
This is not an issue with MediaPortal but with the chipset itself as Windows Vista/7 users do not suffer this issue.

I can't run Microsoft Media Center after installing MediaPortal
After installing MediaPortal, if you try and run Microsoft Media Center (MCE) the TV Section won't work. By default, MediaPortal marks the MCE services
as disabled in the services control panel within Windows. This is done to ensure there are no conflicts between MCE and MediaPortal. A patch can be
installed to configure your preferences and can be found in the MediaPortal forum thread: Setting For MCE Services Stop.

I would like to help out, what can I do?
Please review the Contribute: Get Involved web page which explains the different ways you can help on the MediaPortal project.
For details, consult the Contribute section of this wiki.

Where can I post a bug-report?
First of all, please check if a bug has not already been reported in the Mantis bug tracker, or in the Quality Assurance > Bug Reports forum. If the issue
relates to a development version of MediaPortal, such as an alpha, beta, or RC release, then review and post bugs in the Development > MediaPortal
Alpha's, RC's and SVN-Builds sub forum.
If your bug is not reported there, please read the sticky forum post How to Report Bugs and Get Support thoroughly and then post a new thread which
describes the bug you found in detail.

Where can I post a feature request?
First of all, please check if your request has not already been implemented or is listed in the Improvement Suggestions sub forum.
If it's not, you're welcome to describe your feature with as many details as you can and post it in that Improvement Suggestions forum section. Those
details help the developers to get an idea how the feature should look at the end and helps other users to give some input and enhancements to your idea.
See: Improvement Suggestions for guidance.
Please note: Requesting a feature does not necessarily mean it will be implemented as soon as possible or that it will get implemented at all. Please
refrain from asking questions like: "I have posted a feature request, but still I don't find it in MediaPortal. When will someone put that in?" Feature requests
should be an inspiration for the Team, bugging does not help there. But as many users know, there are a lot of requests that already came to life and
made MediaPortal even better than it was before. The Team always has open ears for new features and ideas.

What is SVN?
SVN is short for SubVersion. SubVersion is a versioning system popular amongst software developers to keep track of changes between them. Each time
a change/fix is committed to the repository, the SVN number increase.
Our developers will sometimes release SVN versions to the public. When used in that sentence, it just means that it is a newer version of MediaPortal that
will contain all updates/fixes/additions up to that specific revision number.
SVN versions should normally be used only for testing purposes, but sometimes it can give you a nice head start on new features if you are willing to take
the risk.
SVN releases are normally based on the latest full release and normally it is possible to apply a SVN version without losing existing settings.
Sometimes you will read in mantis or in a developer's post that a certain issue is fixed in a certain SVN number. That does not mean it is immediately
available for you to download and test. You might have to wait for the next public SVN release or official MediaPortal release to be published.
Read more

How do I make screenshots and attach to forum?
Inside MediaPortal : F11 can be used to capture a screen. It will be saved in My Pictures under MediaPortal directory. Some skins will play a sound file
(like camera shot) but on other skins it might appear as if nothing hapenned. Just check for the mentioned directory and it will be there.
Any other application : like MP Configuration, you can use ALT-PrintScreen to copy the active window to the clipboard. Then use something like Paint to
paste the screen and save as jpg. If there are lots of unused whitespace in Paint, resize the image - in Windows 7: Crop / in XP: First change image
attribute to something very small (like 1 X 1 pixels) and then when you paste the screenprint Paint will auto size to the correct size.
To attach it in a forum post, you must be in Advanced mode and then select the + button to attach. More detailed explanation.

Hardware
Does MediaPortal support my TV tuner?
Please review our list of Supported TV-Cards to determine if your tv tuner is currently compatible with MediaPortal.

How many TV-Cards can I use properly with MediaPortal?
MediaPortal can make use of as many cards you have configured in order to allow multiple recordings, time shifting, watching live TV etc. In some
versions of Windows XP there is a bug in the support for multiple DVB cards within Windows XP itself (specifically the BDA driver stack): the good news is
that there's a fix available, please see the Tuner Issue and channel-scan crash - Windows XP forum thread for further instructions and information. Please
note that those files are not distributed by Team MediaPortal, as they are copyright by Microsoft.

How many LNBs can i use with MediaPortal?
Generally speaking MediaPortal can address 4 LNBs. At the moment switching between LNBs is only supported with Skystar2, firedtv/floppydtv and
Technotrend TV Cards.

Can I run MediaPortal properly with my old DirectX7/8 VGA-Card?
NO. Since MediaPortal uses VMR9 a DirectX 9 compatible video card is required and older cards are not supported.
It is possible that older VGA-cards may also work, but you will have to accept a higher CPU load.
You will find more information on the MediaPortal Requirements page.

If I have a dual tuner card, how many shows can I record/watch at the same time?
You can record two shows simultaneously with a dual tuner card. While recording, you can only view those channels since they are being used by the
tuners. If you are recording with only one tuner, you can scan and watch any other channel with the second available tuner.
If you are using DVB and have multiple channels on a transponder, then one tuner can simultaneously handle (watch/record) all channels on that
transponder drastically increasing your possibilities. See the News Post from 2007: Watch/Record multiple channels with a single DVB TV card?

Can I run MediaPortal properly on a secondary display?
MediaPortal can in most cases run properly on a secondary display.
This can be configured in the Configuration > General by selecting "use screenselector" and setting the appropriate screen in the selection box
afterwards.
Note: The video card does need to support accelerating the content of the secondary screen.

Does MediaPortal support media extenders like the Xbox 360 or Playstation 3?
At the moment there are no media extenders that work with MediaPortal. As a developer you are more than welcome to add support for those.

Does MediaPortal support UPNP A/V or DLNA
MediaPortal 1 doesn't have native support for upnp (although there are plugins that attempt to add this feature) or DLNA out of the box. There are no plans
to introduce support for either of these technologies in MP1, however for MP2 UPNP A/V is definately planned and DLNA is also discussed.

Does my remote control work with MediaPortal?
This depends on your remote control. Currently the following remotes are natively supported by MediaPortal:
Microsoft MCE remotes & keyboard with a certified receiver (no out of the box support for XP Home)
Hauppauge 34- & 45-button remote
ATI & Medion X10 remote (other X10 remote types can be added)
FireDTV
basic support for HID devices (multimedia keys on keyboards, uncertified MCE remote clones)
DirectInput gamepads
All other remotes need some 3rd party applications to send keystrokes or HID commands to MediaPortal (sometimes supplied with your remote). The[ IR
Server Suite|IRSS (IR Server Suite)] (IRSS) plugin offers support for many more remote.

Configuration
Some configuration menus seem to have disappeared. How can I find them?
Make sure you are in expert mode (you can switch between standard and expert mode at the top right in MP configuration).

How do I select more than one folder when setting up Shares in Configuration?
The selection of a single folder in the configuration is optional. It will indicate the default folder. You can then still navigate up (..) to see the rest.
Alternatively, none of the folders should be ticked in the configuration. Then you will by default see all.

TV

What is the default recording format and how can I change this?
The MediaPortal TV-Server records in *.ts file format. The ts container stores the data of every TV Channel as received. This means it includes all audio
tracks, dvd subtitles, etc.

Where will my recordings be saved by default and how can I change this?
The default path is: My Documents\My Recordings
To change the default: Configuration > TV-Server > Recording

Is it required to start MediaPortal to record a scheduled TV Show?
No, the TV-Server runs as a Windows service independently of the MediaPortal application. However, you must schedule the recording first in MediaPortal.

Can I watch encrypted channels with MediaPortal?
Yes, you can watch encrypted channels, if you have a valid subscription card for the channels you want to watch.
MediaPortal does NOT support soft CAMs and will never support them! Furthermore you need a TV card with CI that is properly supported. Currently only
two kinds of cards are confirmed to be working with CI. Others might also work but that still needs to be tested thoroughly.
See Supported TV Cards to find out which cards support a common interface (CI) for channel decryption.

The playback of TV is horizontally cut into halfs, what is that?
This is called "Tearing".

'Shift'+'1' -> What does the displayed info mean?
Example: 0.00fps (1280x720), 100 backbuf X8R8G8B8, adaptor X8R8G8B8 (D16) False VMR9 49.69 fps 47.41 sync: 0 drawn: 19083 dropped: 19 jitter: 18
0.00fps: These are the frames drawn per sec for the GUI. When you are watching tv/video/dvd with VMR9 then this should be 0.00fps since the
GUI is then drawn by VMR9 and not by MediaPortal. If you are using overlay (or you are not watching TV/video/DVD) then this represents how
fast the GUI gets drawn. Note you can specify the max. fps in MediaPortal's settings screen.
(1280x720): Current resolution MP is working in
100: Is a debug number, ignore it
backbuf X8R8G8B8, adaptor X8R8G8B8 (D16): This tells you which DirectX screen format is being used. Again you can safely ignore it.
False: You can ignore this
VMR9 49.69: Indicates VMR9 is active and that its drawing 49.69 video frames/sec
fps 47.41: The average frame rate since playback has been started
sync: 0: The average time difference between when the video frames should have been displayed and when they actually were displayed
drawn: 19083: The number of video frames actually drawn since playback has been started
dropped: 19: The number of video frames dropped by the video renderer
jitter: 18: The average time between successive video frames delivered to the video renderer
And what about the white line moving from left to right? It will display any "tearing" or other breaks in the video "smoothness" - the line
should be continuous and move smoothly.

How do I add TV Logos to the EPG?
See Channel Logos for details how to obtain the logos and add them to your EPG.

How do zoom modes work?
See Video Zoom Modes for a description.

Videos
See also: Stuttering Playback

Can I watch VCDs or SVCDs with MediaPortal?
Yes, you can. See Using MediaPortal > DVD/Disc

How can I play files with multiple audio streams?

You have to install the Haali Media Splitter. The stream can be switched with the 'A' Key or Green Button.
Don't forget to tick every supported-format checkbox (e.g. "AVI", "MKV", etc) when you install Haali's Splitter.
See our Codec Guide for more information.

Some .mkv files fail to start playback?
In Windows, Goto Start Programs >Haali Media Splitter and choose "Media Splitter Settings". Under the Options tab > Compatibility set "Autoload VSFilter"
to "yes". In some Haali versions it's "Preload".
Also make sure you have VSFilter/Direct VobSub installed
See our Codec for more information.

The playback of the video is horizontally cut into halves, what is that?
This is called "Tearing".

What can I do against "Tearing"?
When using Video Mixing Render 9 ([ GuideVMR-9|VMR-9]), Tearing can be prevented in by enabling Exclusive DirectX mode. This setting can be found
in Configuration > Codecs and Renderer > Video Renderer under the Video Mixing Render 9 (VMR9) settings
Also try setting the v-sync of your graphics card to a multiple of the video FPS. Eg. PAL 25FPS -> 50 / 75 / 100 Hz.
See our Stuttering Playback guide for further information

How do I play Quicktime movies in Mediaportal
See Preparing Your System > Codecs, especially the Quicktime Setup guide.

Why am I getting no sound when playing DVDs or videos with AC3 audio?
Your AC-3 codec may be configured to output to SPDIF instead of your speakers.
Open Windows Media Player
Click Tools -> Options
Select DVD tab and press Advanced
ensure the AC3 and DTS decoder settings are set to decode to speakers and not to SPDIF.

How do zoom modes work?
See Video Zoom Modes for a description.

DVD playback
Why do i just get a blackscreen instead of a menu on some DVDs?
This is a codec related problem.
We strongly recommend that you always use DVD Navigator, audio/video codecs from the same brand - for example PowerDVD, or the Windows 7
codecs. If you try to combine DVD Navigator and audio/video codecs from different manufacturers, then you will encounter problems with menus of some
DVDs.

How do zoom modes work?
See Video Zoom Modes for a description.

Music
How do I switch to a full screen visualization when playing a song in MediaPortal?
Hit X or your full screen keyboard shortcut. On some remotes the red button is mapped to full screen as well.

I saw nice album pictures on some screenshots, where can I add them?
Album art is added for all songs scanned and added to your music database, see Configuration > Music > Database
Or, you may manually add a folder.jpg image to your album folder in Windows. If such a file is detected by MediaPortal, it will be displayed as the album art
when any song in that folder is playing. Note, you will need to have each album stored in a separate folder.
To use an image for a single track, name the image file the same as the audio file but with a .tbn extension. This acts as a thumbnail image that will be
displayed when the file is playing. For example, given a song called song1.mp3, name the image for this file song1.tbn.

My music files have different volume levels, how can I avoid adjusting volume on every song
change?
You could try Foobar 2000 as external player. It has an option called "Replay Gain". Scan your collection once, activate it in Foobar's configuration and
enjoy seamless track changes. Hint: Change the default settings from ape tags to ID3v2.

Radio
How do I add Radio Logos?
See Channel Logos for details about how to obtain the logos and add them to your EPG.

General Development
Can I compile MediaPortal on my own?
Yes. MediaPortal is open source. You can get all sources and compile it on your own. See Compiling.

Where can I find and download the MediaPortal source code?
The MediaPortal source code is stored on our production server, with a backup on Sourceforge.
Please see Contribute > Development > SVN for a list of the URLs and instructions.

What's the size of MediaPortal source code?
The MediaPortal source code is about 160MB. However, SVN uses compression so only 66MB need to be downloaded, if you download the needed main
trunk only. All other branches should not be downloaded.

I have changed some code, how can I make it available to the public?
If you have patches or additions to MediaPortal, upload WHOLE files (no diffs) to the SourceForge patches section. Please note that you need an account
for that, we cannot accept anonymous submissions.
As soon as the patch is checked, tested and approved, it will be added to the SVN repository by a team developer. This way we can make sure that your
patch does not break MediaPortal for other users.

I have coded a plugin/skin/whatever. How can I make it available to the public?
First you should release it in our Extensions forum for testing. Once you feel it is ready for public use, you can submit it to our Downloads Repository. See
Extensions > Download Repository for instructions on adding your extension.
MediaPortal provides as standard installer for all extensions called the MediaPortal Extensions Installer or MPEI. The installer also allows users to browse,
update and even configure extensions, so it is a great way to make your extension more visible to the public.
Please be sure to choose the correct category and fill in as many fields as you can, as this helps users who are going to download your extension. The
upload will be approved by our administrators as quickly as possible.

Do I have to keep some formatting or coding style when coding for MediaPortal?
Everything added to SVN should follow the Microsoft C# coding style guidelines.

IMPORTANT: Read our Coding Standards and follow our adoption of those guidelines, especially the paragraphs about formatting, indentation and
commenting.
The primary goal for the coding style guidelines (either our own or Microsoft's) is to keep the code readable for everyone. Please also add comments to
your code to make it transparent for other developers. This practice attracts other developers to give some input and fixes for your code. You wouldn't want
to read spaghetti code either, would you?

Skin Development
Is there any documentation for the skin XML files?
Yes, see Contribute > Skins, especially Skin Architecture.

I have changed graphics or skin XML files but don't see a change in MediaPortal.
Skin graphics and XML files are cached, just delete the packedgfx*.* files in the [userdata]\cache\skin folder . They will be rebuilt on the next MediaPortal
start. Or remove the whole [userdata]\cache\skin folder, this will ensure graphics and fonts are rebuilt. See also: Recaching

Performance
Why doesn't MediaPortal perform as well as the application provided with my TV card?
MediaPortal needs to support a large range of TV cards. For this it uses the Windows DirectShow API. The applications provided with most TV cards can
communicate directly with the specific TV card and therefore can perform better in certain conditions. They can do this because they only need to support
a very limited set of hardware and the provided applications typically have a limited feature set compared to MediaPortal.

Why does MediaPortal use DirectX9 Video Mixing Renderer (VMR9) for Video Playback?
VMR-9 mode is used for TV and video playback for a number of reasons. The most important ones are:
Drawing GUI on top of the video doesn't flicker. This enables on-screen displays to be drawn over the live TV images.
DXVA can be used in hardware if the codec & hardware supports it
Better image quality
Better scaling quality
VMR-9 has improved timing code
It can work in Direct3D exclusive mode which means the entire machine is set to fullscreen and no background application are allowed access to
the video hardware. Under Direct3D Exclusive Mode, less CPU is required to play videos and depending on the resolution of the video, playback
may be smoother. Exclusive mode is also required to stop tearing.

Would a stripped-down version of MediaPortal be faster?
No. MediaPortal is already modular and modules which are not used can be disabled in settings. However, removing code for those parts which you do not
want to use will not improve the performance of MediaPortal or its basic hardware requirements.
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