Page tree

  Wiki Navigation

    Loading...


 Recently Updated


 Latest Releases

 MediaPortal 1.24 
            Releasenews | Download
 MediaPortal 2.2.3
            Releasenews | Download

Purpose

  • Required:  Yes (if plugin uses
    MP.DB.Music
    or
    MP.Plugins.Music
    subsystem)
  • Type of Change:  Rework

Description of Change

The Audioscrobbler plugin (and therefore the whole Audioscrobbler code) was removed and integrated in LastFM. Plugins which use dependencies of Audioscrobbler need to remove them.

Compatibility

See the version compatibility  article for more information.

This change resulted in an increase of the compatibility version of the

MP.DB.Music

subsystem and

MP.Plugins.Music

. This means, that if your plugin has an

[UsesSubsystem("MP.DB.Music")]

or

[UsesSubsystem("MP.Plugins.Music")]

attribute, you need to update your compatibility information. Your unchanged plugin won't install and work anymore on a MediaPortal 1.6 installation.

Changing the compatibility information is done in the

CompatibleVersion

attribute. If your plugin isn't affected by the changes or you update your plugin in a way that keeps it compatible with MediaPortal 1.2, 1.3, 1.4, 1.5 and 1.6, you should keep the

minRequiredVersion

value at 1.1.6.27644, otherwise you should increase both versions. The new version number should be 1.5.100.0, which is the version number of the MediaPortal 1.6 Pre Release.

Note: If your plugin is affected by this change but doesn't have the corresponding

UsesSubsystem

attribute, that's a bug in your plugin too. Please add the

UsesSubsystem

attribute for the

MP.DB.Music

and

MP.Plugins.Music

subsystem, and any other subsystem you use, to help improve the user experience in future upgrades.

Additional Information and References

Mantis Issue:

MP1-4274

Subsystem:

MP.Plugins.Music and MP.DB.Music

Author:

Sebastiii

Date added:

Tue, 22 Oct 2013

 

   

 

This page has no comments.